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Getting
Started

Welcome to the OmniVox Voice Processing System for Windows.
This Getting Started guide takes you step by step through setting
up a basic call processing application.  Once you have set up your
phone lines and installed the system, you can begin to use the
OmniVox Application Builder to build your call processing applica-
tion.

Before proceeding with this Getting Started guide, first install the
OmniVox software as instructed in the OmniVox System for
Windows Installation Manual.

The Application Builder
The OmniVox Application Builder makes your application building
tasks simple and easy to use.  The Application Builder allows for
complete scripting of a call processing application.  It includes
facilities for voice recording and playback, information retrieval and
conversion to voice response, information entry and reporting, call
transfer, and call control using touch-tone (DTMF) signaling.

OmniVox simplifies the process of scripting telephony applications
by using a series of icons as building blocks representing the
separate processes during a call.  The icons are linked together to
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create a graphical flow diagram of the application.   The Graphical
User Interface allows cut and paste, copy, highlight,  and many
other easy-to-use editing tools.

After establishing the basic call flow logic, the user can right-click
on an icon to access the underlying command configuration screen.

What can OmniVox Do?
You will want to use your OmniVox System to do the following:

build an application with the Application Builder.

record greetings, instructions and other messages with the
Speech Editor.  (Messages can be recorded on the spot,
using a telephone; they can also be professionally re-
corded and input from audio tape.)

assign telephone lines to your application.

start and stop your application.

check your application using the Monitor option.
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Creating an Application
Creating a new application consists of the following steps:

1. Building the Application

2. Recording the Prompt Messages

3. Assigning the Application(s) to Lines

4. Starting the Application

5. Checking the Application

The sections that follow provide step-by-step instructions for
creating your first OmniVox voice processing application.

About Your Application

You will create a simple application that will
play a welcome message, prompt the caller to
record a message, then record the caller’s
message, and then play back that message.
Finally, the application will quit with a goodbye
message.   The flowchart at left shows what
your application will do.

Four numbered messages will be used to
accomplish these tasks.  The message
numbers and the messages that they will
contain are shown in the following table:

PLAY
3001

3002

RECORD

QUIT
3004

LISTEN
3003
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3001 Welcome to OmniWorld

3002 Please leave your message after the tone.  When
you are done recording, press the # (pound) sign.

3003 The message you recorded is......

3004 Thanks for calling OmniWorld.  Goodbye!

Starting OmniVox
The following steps will enable you to access the OmniVox for
Windows Application.  We assume you are running Windows and
are logged onto your system.

1 From the Windows desktop, click on the Start button,
then point to Programs.  The list of folders for your
program groups will display.

2 Click on the OmniVox folder.  The
OmniVox group menu will display.

3 Click OmniVox to open the
OmniVox Main Menu.

Figure 1.  OmniVox main menu and toolbar

Accessing Application Builder
1 From the OmniVox main menu, select

Tools | Application Builder.

The Application Builder screen will display.

Table 1.  Sample Messages
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Figure 2.  Application Builder screen

2 Enter the name of your new application.  In this example,
enter the name TEST1 in the Application Name field.

3 Enter a 3-character code name in the Application Code
field.  In this example, use TS1.

4 Click on the Automatically Start Application for Test-
ing box.

5 Click on the Line radio button.  It will automatically set
Line 1.

Note:  If this is not the first time that you are using
OmniVox, make sure that there are no applications
using Line 1.  See the Monitor menu in chapter 3 of the
OmniVox User’s Manual.

The Automatically Start OmniView for Application
Editing box is already checked.  This will automatically
start OmniView.

6 Click on the OK button.

The Project screen will display (below).  It is a “split”
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window with a tree view (on the left) and a list view (on
the right).  The relative size of the two view areas is adjust-
able (grab the vertical divider and move it horizontally).

Open the Call Flow
In the tree portion of the Project screen (shown below), under the
Call Flows folder, click on the TEST1 entry (or the name you have
used).  For a new application, the OmniView screen will display a
default set of icons in the call flow window as shown in the follow-
ing typical  new application screen:

This screen contains the following sections:

Figure 3.  Project screen for TEST1 example
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• The command icon palette is displayed in the lower right
section of the call flow window, in this example.

The command icon palette can be moved to other locations on
the screen as you like, by grabbing the palette at its topmost
blue bar and dragging it to another location.

• The top line displays the file name (TEST1.APP.DAT).

• The next line contains the OmniView pulldown menus.

• The next line contains the OmniView toolbar icons.

• The large area contains the call flow window with the call flow
diagram.

Figure 4.  OmniView default application call flow
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Configuring and Editing the
Application
The call flow diagram on the screen is the default OmniView call
flow application.  We will modify it to produce the simple applica-
tion described on page 7.

1 Right-click the mouse on the Start icon (leftmost in the call
flow diagram).  The following screen is displayed:

Figure 5.  Setup screen

2 The fields in the screen are already filled in with the default
values. We want to use these values as they are, so click
on the OK button.

3 Next, since we won’t be needing the GETDTMF and
CONDITION commands in our sample application, we
can remove those icons from the call flow diagram.
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• Left-click on the GETDTMF icon to highlight it, then
press the Delete key (or the Cut icon on the toolbar)
to remove GETDTMF from the call flow.

• Next, left-click on the CONDITION icon and delete
it.

Note: Don’t worry about the connector lines in the call
flow diagram at this point.  We will be placing our own
connectors on our sample application later.

4 The first thing we want to do in our sample
application is play a message.  Right-click on
the Play icon in the call flow diagram.

The following configuration screen will
appear:

Figure 6.  Play configuration screen

5 Enter playit in the Name field.   Enter 3001 in the first
Message field. Then click the OK button.

6 The next command (Record) in our sample
application will allow the caller to record a
message.  Right-click on the Record icon in
the call flow diagram.

The following screen will appear:
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Figure 7.  Record configuration screen

7 Enter the following information and settings in this screen:

• Enter recthis in the Name field.  Enter 3002 in the first
Message field.

• Click on the New radio button, because you are
creating a new recording.

• Enter 60 in the Max Seconds to Record field, so that
you can record a 60 second message.

• Enter 2 in the Max Seconds of Silence field, so that
you will have no more than 2 seconds of silence on
your message.

• Remove OF1 from the Record Message field, and
remove ZZZ from the CNA Code field.

• Click on the Pound radio button.  This will allow
the caller to press the pound sign when they are
finished recording their message.

• Click on the Beep radio button, so that your record
message will beep.

• Click on the OK button to save this data.
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8 Next, we want to be able to hear the mes-
sage we recorded.  Right-click on the Listen
icon in the call flow diagram.

The following screen is displayed:

Figure 8.  Listen screen

• Enter playback in the Name field.  Enter 3003 in the
first Message field.

• Click on the OK button to save this data.

9 The final action in the call processing proce-
dure is to hang up the line and stop the
application.  Right-click on the Quit in the
call flow window:

The following screen will appear:

Figure 9.  Quit screen

• Enter goodbye in the Name field.  Enter 3004 in the
first Message field so that the quit message will be
played.

• Click on the OK button.
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Connecting the Icons
Next, we will connect the icons together.  First, we need to remove
any existing connectors from the call flow diagram.

• Click on the Selector icon  in the OmniView
toolbar.

• Move the cursor to a connector line and left-click
on it.  Two little handles will appear at either end of
the line indicating that the line has been selected.
Select the Cut  icon.

• The connector line will disappear.

• Select and cut any remaining connector lines.

Now we will connect the five icons in the call flow diagram.
The two connector icons in the toolbar allow you to select
either free style lines  or square lines .

1 Select the line style that you wish to use by clicking on
one of  these icons.

2 Position the mouse on the Start icon.  Left-click the
mouse button and hold it down while dragging the
mouse to the Play icon.  When you release the mouse
button, a line will appear connecting the Start icon to
the Play icon.

3 Repeat step 2  to connect the Play icon to the Record
icon, and then to connect the Record icon to the
Listen icon.

• When you connect the Record icon to
the Listen icon, a connector option
dialog box like this will be displayed:
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Your application is now complete.  Note that the name you
gave to each command is displayed below the corresponding
icon:

Figure 10.  Completed sample application diagram

Saving your Application
To save your application, open the File menu and select Save.
The file will be saved under the path and name
\usr\apex\appdata\appgen\TEST1.APP.

Recording the Messages
Now we need to record the messages that the sample applica-
tion will use.  The messages are listed in Table 1 on page 8.

1 In the Project tree area, double click on TEST1 under
Voice Directories to open that directory and display its
contents.  In the list area, nothing is displayed (because
no voice prompts have yet been recorded for TEST1).

2 In the OmniView menu bar, click File, then New, then
click OmniView Voice Prompt.

A screen similar to this will display:

• Click on the Good box.  A check mark will appear.
Click on the OK button.

4. Finally, connect the Listen icon to the Quit icon.
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Figure 11.  Speech Editor screen

3 Activate the telephone line that will be used for recording
the messages.

• From any telephone, dial the line on which
OmniVox will be recording.

• When it rings, select Open from the Line pulldown
menu to activate the line.

The Set Line Number screen is displayed:

Figure 12.  Set Line Number screen

• Click on the OK button.  This will activate your
line number 01, and the phone will stop ringing,
indicating that the connection has been made.

4 Now record the first message (3001).

• Make sure that the Speaker button is not pressed
down on your telephone.

• Click on the Record button in the toolbar. 
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• At the tone, record your message by saying
Welcome to OmniWorld directly into the handset.
Your message will be recorded.

• Click the Stop button to stop recording.

• Type  a description of your message (or a transcrip-
tion) into the text DES area at the botom of the
voice prompt screen (Figure 11).

• Save this recorded message and its associated
description file. Select Save As from the File
menu. Make sure the path for your file name is
correct (in this example it is usr/apex/voice/
TEST1). Give your voice prompt a file name (3001
in this example). Click the OK button.

5 The next message number will be 3002.  We can have
our message numbers set automatically by selecting
Set Start Message Number from the Options menu.

A screen similar to this is displayed:

Figure 13.  Set Message screen
• Enter 3001 in the Start Message Number field.

Click on the OK button.
• To record the second message, select File | Open

Next.  A blank screen for message 3002 will display.
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Playing Back the Messages
Now play back the messages to check them.  Each message
has a graphic representation on the screen.

• Make sure that the Speaker button is pressed down
on your telephone.

1 Place and click the cursor at the beginning of a mes-
sage (far left side) to hear the entire message.  If you
want to hear only a particular section, highlight that
section by dragging the cursor through  it.

2 Click on the Play button. 

Your message will be played back.

You can check each of your messages by activating the
window for that message number and positioning the
mouse at the beginning of the message, and then
clicking on the play button.

• Repeat step 4 to record message 3002.  Speak
directly into the handset to record your message,
saying “Please leave your message after the tone.
When you are done recording, press the pound
sign.”

• Select File->Save As to save message 3002.

6 Now record the third message.

• Select File->Open Next.  Note that a blank screen
for message 3003 is displayed.  Repeat step 4 to
record the message “The message you recorded is
... (pause).”

7 Repeat the above steps to record message 3004,
“Thanks for calling OmniWorld.  Goodbye.”
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Editing Messages
If you want to edit your new message, select the Edit pulldown
menu and you can cut, copy, and paste sections of your message.
For details, see chapter 5, Speech Editor, in the OmniVox User’s
Manual.

Deleting a Voice Prompt
If you wish to delete a recorded voice prompt, use Windows
Explorer to do so.  Locate the directory
\usr\apex\voice\<application name> and delete both the voice
prompt file and its associated .DES file.

Assigning the Application to a
Phone Line
The OmniVox System option provides a simple way to asign
your new application to a dedicated telephone line.

1 Select System from the OmniVox main menu. The
following screen is displayed:

Figure 14.  System menu
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Figure 15.  Line Manager screen

In the example above, the line with the TEST1 application is
already selected.

• To select a particular line, double-click the mouse
on the box in the Line column.  An x will appear in
the box.

3 Click on the Assign button to assign a particular
application to a line.   A screen similar to this will
display:

2 Select Line Manager from the System menu to assign
your application.  A screen similar to this will display:
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Figure 16.  Assign screen

• Enter your application name, TEST1, in the Appli-
cation field.

• Enter TS1 in the Code field.

• Click on the OK button to save this data.

4 In the Line Manager screen, your application name
and code will be displayed.  (In the example in Figure
15, the name TEST1 and the code TS1 already appear.)

5 Click on the Config option (if it is active) to configure
your application for either Voice, which is the default,
or Voice/FAX, which is used for FAX applications.

Note: If you do not have the FAX module installed, the
Config button will not be active.  See chapters 9 and
10 of the User’s Manual for details concerning FAX
applications.

6 Click on the Debug Level button to open the Debug
Level options box.  A screen similar to this will appear:
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Figure 17.  Debug Level screen
• In the Level section, click the All On to display

debugging information for all levels.

• In the Select Lines section. click the From Line _
To Line _ button, and enter the line number that
your application is on (line 1, in this example).

• Then click OK.

7 In the Line Management screen once again, click the
Update button to update the database by putting all the
information on the screen into the database.

8 In the Show section of the screen, click on the Normal
radio button.  (This will open a DOS text window for
the debug report screen, when you start your applica-
tion.)

9 Click on the Start button.  Your application will be
started on the selected line.
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Figure 18.  Debug window
• Click the close button  to close this window, and then

close the Line Management screen.

Checking Your Application
To check to make sure that your application is running properly,
use the Monitor option, which allows you to see what port your
application is running on.

1 Select Monitor from the OmniVox Main
Menu.

2 Select Lines from this menu, and the following
screen is displayed (next page):

• A debug window will appear.  This window tells
you that your application is running, and is useful
in diagnosing any problems.  A sample debug
window is shown here.  Use the vertical scroll bar
to view upper portions of the report.
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Figure 19.  Line Information screen
• The application code, TS1, appears next to line 1,

which is the line that is being used.  This screen
shows that the application is running and waiting
for calls.

• Use the vertical scroll bar to display lower portions
of the lists of lines.

3 Dial the line that you have assigned to Line Number 01
from your telephone handset and your new application
messages will play back automatically.  Make sure the
speaker button is pressed down.  Note how the Record
Name field changes from playit to goodbye as your
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application progresses.

4 Click on the Close button when you are finished.

Congratulations!  You have just completed your first
application.


